end0tknr's kipple - 新web写経開発

http://d.hatena.ne.jp/end0tknr/ から移転しました

DBD::Pg ver.1.22なら ActivePerl 5.8.8.824 でも動作?

ActivePerl for winのPPMでDBD::Pgをインストールしようとしても、標準のリポジトリにはDBD::Pgがありません。


ActivePerlへのDBD::Pgのインストール方法を紹介しているページをいくつか見つけましたが、私の環境にあるActivePerl 5.8.8.824ではmsvcr80.dllやPg.dllに問題があるようで、正常に動作しませんでした。

http://mofumofusan.blogspot.com/2008/01/activeperldbd-pg.html
http://d.hatena.ne.jp/higurasias/20080828
http://www.kana.mydns.jp/etc/index.html


次のurlでDBD-Pg.zip (ver.1.22)が配布されていますが、このDBD::Pg ver.1.22であれば、私の環境でも今のところ動作しています。

http://www.cs.cmu.edu/~blangner/perl/dbd_pg.html



同じように苦労されている方がいらっしゃれば、試してみるのもいいかもしれません。